Issue when inviting new users
Incident Report for ContentCal
Resolved
This issue has now been resolved. Thank you for your patience, and apologies for any inconvenience.
Posted Sep 03, 2019 - 10:59 BST
Investigating
We have a temporary issue with inviting new users to ContentCal. We're currently looking into this.
Posted Sep 02, 2019 - 17:17 BST
This incident affected: ContentCal Apps (Web App).