Issues with live chat
Incident Report for ContentCal
Resolved
Intercom is back to normal. Thanks for bearing with us and apologies for any inconveniences
Posted Nov 12, 2021 - 16:55 GMT
Investigating
There are some on-going issues with Intercom, the system we use for live chat. This may affect how quickly our support team reply to your messages.

We're monitoring the issue closely and as soon as there is an update we'll let you know.
Posted Nov 12, 2021 - 16:31 GMT
This incident affected: ContentCal Web Apps (Web App).